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1. Introduction

Thank you for your interest in the AEK-CY8C20xx7 QuietZone™ CapSense® Starter Kit. This docu-
ment explains how to develop best-in-class capacitive touch sensing solutions using the QuietZone
family of CapSense controllers.

1.1 Kit Contents
■ AEK-CY8C20xx7 board with CY8C20247S-24LKXI

■ 5-pin connector

1.2 Additional Requirements
■ Hardware

❐ MiniProg3

❐ USB A to Mini-B cable

❐ Connecting wires and copper tape

❐ Soldering iron

■ Software

❐ PSoC® Designer™ (version 5.2 or higher)

❐ PSoC® Programmer™ (version 3.14 or higher)

❐ Bridge Control Panel

1.3 Cypress's CapSense Controller - CY8C20247S-24LKXI Features 

The Cypress CY8C20247S-24LKXI is a low-power, high-performance, programmable CapSense 
controller offered in a 16-pin QFN (3 mm x 3 mm).

1.3.1 Advanced Touch Sensing Features

■ Programmable capacitive sensing elements 

❐ Supports a combination of CapSense buttons, sliders, and proximity sensors

❐ Integrated API to implement buttons and sliders

❐ Supports up to 10 capacitive sensors and two sliders

❐ Supports a parasitic sensor capacitance range of 5 pF to 45 pF

■ SmartSense™ Auto-tuning enables fast time-to-market

❐ Sets and monitors tuning parameters automatically at power-up and at runtime 

❐ Design portability – self-tunes for changes in the user’s design 

❐ Environmental compensation during runtime 

❐ High sensitivity - 0.1 pF
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■ Enhanced noise immunity and robustness

❐ SmartSense_EMCplus™ automatically compensates for environmental and manufacturing 
variations

❐ SmartSense_EMCplus offers superior noise immunity for applications with challenging con-
ducted and radiated noise conditions

❐ Internal regulator provides stability against power supply noise

❐ Integrated API of software filters, which improve signal-to-noise ratio (SNR)

■ Ultra low-power consumption

❐ Three different power modes for optimized power consumption 

❐ Active, sleep, and deep-sleep modes (deep-sleep current: 100 nA) 

❐ 28 µA per sensor at 125 ms wake from sleep rate 

1.3.2 Device Features 

■ High-performance, low-power M8C Harvard-architecture processor

❐ Up to 4 MIPS with 24-MHz internal clock 

■ Flexible on-chip memory

❐ 16 KB of flash and 2 KB of SRAM 

❐ Emulated EEPROM supported 

■ Precision, programmable clocking

❐ Internal main oscillator (IMO): 6/12/24 MHz ± 5% 

❐ Option for precision 32-kHz external crystal oscillator

■ Enhanced general-purpose input output (GPIO) features

❐ 10 general-purpose I/Os (GPIOs) with programmable pin configuration

❐ 25-mA sink current/GPIO and 120-mA total sink current/device

❐ Internal restive pull-up, Hi-Z, open-drain, and strong drive modes on all GPIOs 

■ Peripheral features

❐ Three 16-bit timers 

❐ I2C – master (100 kHz) and slave (400 kHz) 

❐ SPI – master and slave – configurable range: 46.9 kHz to 12 MHz 

❐ 10-bit incremental ADC input range: 0 to 1.2 V

■ Operating conditions

❐ Wide operating voltage: 1.71 V to 5.5 V 

❐ Temperature range: –40 °C to +85 °C

1.4 Factory Default Configuration

The AEK-CY8C20xx7 QuietZone CapSense Starter kit board is not pre-programmed; the entire
flash memory of the CY8C20247S-24LKXI is available.
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1.5 Additional Educational Resources

Visit http://www.cypress.com for additional educational resources, including Datasheets, Design
Guides, Technical Reference Manuals, and Application Notes.

■ CY8C20247S-24LKXI

❐ Datasheet - http://www.cypress.com/?rID=59671

❐ Design Guide - http://www.cypress.com/?rID=63035

❐ Getting Started with CapSense - http://www.cypress.com/?rID=48787

❐ Technical Reference Manual - http://www.cypress.com/?rID=59964

❐ Application Note: Host Sourced Serial Programming - http://www.cypress.com/?rID=42958

■ PSoC Designer overview and latest releases - http://www.cypress.com/go/psocdesigner

■ MiniProg3 overview and latest releases - http://www.cypress.com/?rID=38154

1.6 Documentation Conventions 

Convention Usage

Courier New
Displays file locations, user-entered text, and source code:
C:\ ...cd\icc\

Italics
Displays file names and reference documentation:
Read about the sourcefile.hex file in the PSoC Designer User Guide.

[Bracketed, Bold]
Displays keyboard commands in procedures:
[Enter] or [Ctrl] [C]

File > Open Represents menu paths: File > Open > New Project

Bold
Displays commands, menu paths, and icon names in procedures:
Click the File icon and then click Open.

Times New Roman Displays an equation: 2 + 2 = 4

Text in gray boxes Describes cautions or unique functionality of the product.

http://www.cypress.com
http://www.cypress.com/?rID=59671
http://www.cypress.com/?rID=63035
http://www.cypress.com/?rID=59964
http://www.cypress.com/go/psocdesigner
http://www.cypress.com/?rID=42958
http://www.cypress.com/?rID=38154
http://www.cypress.com/?rID=48787
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2. Software

This chapter describes how to install the software required to operate the AEK-CY8C20xx7
QuietZone CapSense Starter Kit.

2.1 PSoC Designer

Cypress’s PSoC Designer is a revolutionary integrated design environment (IDE) that you can use to
customize PSoC to meet your specific application requirements. You can develop applications using
a library of pre-characterized analog and digital peripherals in a drag-and-drop design environment.
Then, customize your design using the dynamically generated API code libraries. Finally, debug and
test your designs with the integrated debug environment, including in-circuit emulation and standard
software debug features.

Download PSoC Designer for free from http://www.cypress.com/go/psocdesigner.

1. To open the application, click Start > All Programs > Cypress > PSoC Designer <version> 
> PSoC Designer <version>.

2. Click File > New Project to create a new project; click File > Open Project to work with an exist-
ing project.

3. To experiment with the example projects, go to the Example Projects chapter on page 26.

http://www.cypress.com/go/psocdesigner
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Figure 2-1.  PSoC Designer Interconnect View

Note  For more details on PSoC Designer, see the PSoC Designer IDE Guide located at:

<Install_Directory>\Cypress\PSoC Designer\<version>\Documentation

See Additional Educational Resources on page 6 for links to PSoC Designer training. The PSoC
Designer Quick Start Guide is available at http://www.cypress.com/?rID=47954.

User Module Catalog

User Module Wizard

Workspace Explorer

Datasheet

Chip Editor View

http://www.cypress.com/?rID=47954
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2.2 PSoC Programmer

PSoC Programmer is a stand-alone utility for programming PSoC devices.

1. Click Start > All Programs > Cypress > PSoC Programmer <version> > PSoC Programmer 
<version>.

2. Select the MiniProg from Port Selection, as shown in Figure 2-2.

Figure 2-2.  PSoC Programmer Window

3. Click the File Load button to load the hex file.

4. Use the Program button to program the hex file onto the chip.

5. When programming is successful, “Programming Succeeded” appears in the Actions pane.

6. Close PSoC Programmer.

Note  For more details on PSoC Programmer, see the user guide at the following location:

<Install_Directory>\Program Files\Cypress\Programmer\<version>\Documents

Load
Program

Power
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2.3 CapSense Data Viewing Tools

During the CapSense design process, you need to monitor the sensor data, such as raw counts,
baseline, and difference counts, for tuning and debugging. The Bridge Control Panel application
collects and charts the data using the I2C communication interface.

2.3.1 Bridge Control Panel (BCP)

The Bridge Control Panel is used with the MiniProg3 to enable communication with I2C slave
devices. This program configures I2C devices and acquires and processes data received from the
I2C slave devices. The Bridge Control Panel helps to optimize, debug, and calibrate the target
applications.

The main features of the application are:

■ Controls the power supply of connected devices

■ Supports the I2C protocol

■ Searches and displays a list of devices connected to the bridge

■ Supports high-speed data reading from the slave device (ToFile mode of bridge)

To open the application, click Start > All Programs > Cypress > Bridge Control Panel <version>.

Figure 2-3.  Bridge Control Panel Window

Note See Cypress Application Note AN2397: CapSense Data Viewing Tools for additional details.

Tool Buttons
Tabs

Command 
Strings

Results 
Window

Commands 
Window

Power Supply 
Control

Status Bar
Connected 

Bridges

Transfer 
Control Buttons

http://www.cypress.com/?rID=2784
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2.4 Example Projects

The example projects are available in a zip file for free download from
http://www.artaflexmodules.com/quietzone.

The zip file contains three PSoC Designer example projects that implement a button, a slider, and
proximity sensing using the CY8C20xx7. The example projects can be extracted to any directory of
your choice and will be referred as ‘Projects Directory’ in this document. The example projects
folders also contain Bridge Control Panel configuration files, which can be used to read the
CapSense data using the Bridge Control Panel tool.

The example projects provided with the AEK-CY8C20xx7 QuietZone CapSense Starter Kit are:

■ Proximity with CY8C20xx7

This example project uses the CSDPLUS user module to implement proximity sensing using a 
wire loop sensor. The example project uses the EzI2Cs user module to transmit the required 
CapSense parameters. The CapSense data can be viewed on a PC using the Bridge Control 
Panel tool.

■ Button with CY8C20xx7

This example project uses the SmartSense_EMCplus user module to implement a CapSense 
button. SmartSense Auto-tuning tunes the sensor automatically at power-up; it then monitors and 
maintains optimum sensor performance during runtime. The example project uses the EzI2Cs 
user module to transmit the required CapSense parameters. The CapSense data can be viewed 
on a PC using the Bridge Control Panel tool.

■ Slider with CY8C20xx7

This example project uses the SmartSense_EMCplus user module to implement a five-segment 
slider. The example project uses the EzI2Cs user module to transmit the required CapSense 
parameters. The CapSense data can be viewed on a PC using the Bridge Control Panel tool.

The Proximity with CY8C20xx7 example project is explained in detail in Getting Started with the
Proximity Sensor Project on page 16. For an explanation of the Button with CY8C20xx7 and Slider
with CY8C20xx7 example projects, see the Example Projects chapter on page 26.

http://www.artaflexmodules.com/quietzone


AEK-CY8C20xx7 QuietZone CapSense Starter Kit User Guide 12

3. Kit Operation

The AEK-CY8C20xx7 QuietZone CapSense Starter Kit enables the evaluation of the
CY8C20247S-24LKXI. The kit has a 5-pin header to connect with the Cypress MiniProg3. You can
either build your own sensor board or use connecting wire and copper tape to quickly evaluate the
CY8C20247S-24LKXI in your systems. You can achieve proof-of-concept designs, then spin a PCB
for the next level of development cycle.

3.1 Hardware Requirements
■ AEK-CY8C20xx7 QuietZone CapSense Starter Kit with CY8C20247S-24LKXI

■ 5-pin connector for ISSP header

■ MiniProg3

■ CY3240-I2USB bridge (optional)

■ USB A to Mini-B cable

3.2 Connecting CapSense Hardware

The AEK-CY8C20xx7 QuietZone CapSense Starter Kit has a 14-pin edge connector, which includes
10 GPIOs, VDD, GND, and two LED pins. You can directly connect the button and slider hardware to
any of the available GPIOs. If your designs lack hardware, you can still configure buttons, sliders,
and proximity sensors by connecting GPIOs directly to copper tape cut in the desired shape. This
section describes common UI configurations using connecting wire and copper tape. Table 3-1 gives
a couple of examples of copper tape that can be purchased from Digi-Key, an online catalog
distributor. 

3.2.1 Proximity Sensors

A proximity sensor can detect the presence of nearby objects without any physical contact. The
sensor may be a copper pad, PCB trace, or a wire loop, as defined in Getting Started with the
Proximity Sensor Project on page 16, and is tuned for higher sensitivity than touch sensing. 

Table 3-1.  Example Copper Tape Part Numbers

Part Number Digi-Key Part Number Digi-Key Description

3M1125C-1YD 3M1125C-1YD-ND TAPE COPPER FOIL 25.40X914.4MM

3M1125D-1FT 3M1125D-1FT-ND TAPE COPPER FOIL 152.4X304MM

www.digikey.com
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Figure 3-1.  A Proximity Sensor Implementation Using Copper Tape as a PCB Trace

Figure 3-2.  A Proximity Sensor Implementation Using a Wire Loop

3.2.2 Buttons

A button is a copper sensor connected directly to a CapSense I/O. The simplest capacitive sensor
consists of a circular pad built from the copper tape. This circular copper pad is then connected
directly with a connecting wire to a CapSense I/O available via the 14-pin edge connector.
Optionally, scotch tape can be used as an overlay to cover the sensor. Other examples of overlays
are clear plastic or glass up to 5 mm in thickness.
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Figure 3-3.  A Simple ~10-mm-Diameter Button Using Copper Tape

3.2.3 Sliders

Sliders are used for controls requiring gradual adjustments. Examples include lighting control
(dimmer), volume control, graphic equalizer, and speed control. A simple linear slider is built using
an array of capacitive sensors called segments that are placed adjacent to one another. The
capacitive sensors can be in a rectangular shape and built from the copper tape. These sensors can
then be connected directly to the CapSense controller I/O pins assigned in firmware to drive these
segments. Optionally, scotch tape can be used as an overlay to cover the sensor. Other examples of
overlays are clear plastic or glass up to 5 mm in thickness. 

Figure 3-4.  Slider Implementation Using Copper Tape

Refer to Getting Started with CapSense for design guidelines of CapSense buttons, sliders, proxim-
ity sensors, and LEDs for visual touch feedback.

10 mm

8 mm

8 mm

http://www.cypress.com/?docID=41662
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3.3 Programming CY8C20247S-24LKXI
1. Solder the 5-pin connector directly to the HD1 header of the starter kit.

Figure 3-5.  Starter Kit with 5-pin Connector

2. Connect the USB port of your PC to the AEK-CY8C20xx7 ISSP connector using the MiniProg3 
and USB A to Mini-B cable.

Figure 3-6.  Connect the MiniProg3 Programmer

3. Launch PSoC Programmer by clicking Start > All Programs > Cypress > PSoC Programmer 
<version> > PSoC Programmer <version>.

4. Using the PSoC Programmer software, program the CY8C20247S-24LKXI with the hex file for 
the proximity sensor project located at: <Projects Directory>\StarterKit_Example 
Projects\Proximity with CY8C20xx7\Proximity_with_CY8C20xx7\Proximity_ 
with_CY8C20xx7.hex
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Figure 3-7.  PSoC Programmer

5. After the “Programming Succeeded” message appears in the Actions pane, reset the device by 
clicking the Power button twice to turn the device off and on.

3.4 Getting Started with the Proximity Sensor Project

Follow the steps in Programming CY8C20247S-24LKXI on page 15 and select the proximity sensor
project. This example project demonstrates the proximity-sensing capabilities of the QuietZone
controller family and enables you to quickly evaluate the AEK-CY8C20xx7 QuietZone CapSense
Starter Kit. 

The prerequisites for this example are:

■ USB A to Mini-B cable

■ MiniProg3

■ Two connecting wires

■ Soldering iron

Load

Program

Power
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Figure 3-8.  Proximity Project Prerequisites

The pin assignments used in this example project are:

■ Proximity sensor (wire loop) - P2[3]

■ LED - P1[4]

You can assign any available pin on the 14-pin edge connector for the wire sensor, using the
CSDPLUS User Module Wizard. Refer to the user module datasheet, accessible through PSoC
Designer, for information about configuring pins using the User Module Wizard.

■ To open PSoC Designer, click Start > All Programs > Cypress > PSoC Designer <version> > 
PSoC Designer <version>.

■ Click File > Open Project. Browse to <Projects Directory>\StarterKit_Example 
Projects\Proximity with CY8C20xx7\proximity_with_CY8C20xx7 
\proximity_with_CY8C20xx7.app 

3.4.1 Firmware Operation

■ Global interrupts are enabled and the CSDPLUS User Module is started.

■ All sensors are scanned continuously in an infinite loop.

■ Filters (median, average, and IIR) are enabled to improve performance against noise.

■ When a valid proximity event is detected, the corresponding LED (LD1 in this example) is 
switched on; the LED is switched off when the detected object moves out of the detection range. 
Please note LD1 and LD2 indicate physical LED, while LED1 and LED2 indicate corresponding 
pins on the 14-pin edge connector.
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3.4.2 Running the Example Project

1. Coil the connecting wire to form a loop of ~3 cm in diameter.

Figure 3-9.  Wire Loop

2. Solder the wire loop to pin labeled P23 on the 14-pin edge connector and solder together the pins 

labeled LED11 and P14 with another connecting wire.

Figure 3-10.  Starter Kit Connections

3. Set voltage to 1.8 V and click on the Power button in PSoC Programmer to power the starter kit. 
See Figure 3-11.

1. The two pins on the 14-pin edge connector that provide connections to the LEDs are labeled LED1 and LED2. These labels are located on
the back side of the kit. The two LEDs on the front side of the starter kit are labeled LD1 and LD2.

P23

P14

LED11LD11
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Figure 3-11.  PSoC Programmer Settings

Figure 3-12.  Starter Kit with MiniProg3

4. Move your hand toward the loop; when your hand is within the proximity detection range, the LED 
LD1 will turn on. This example project enables a proximity detection distance of approximately 3 
cm. Make sure that the wire loop is coplanar with the starter kit to ensure optimal proximity sens-
ing.

Power
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Figure 3-13.  LED Glows on Proximity Detection

3.5 Monitoring Sensor Data Using the Bridge Control Panel

The proximity sensor project uses the I2C as the communication interface to output CapSense
parameters. The MiniProg3 is used as the I2C-USB bridge to read CapSense parameters from the
AEK-CY8C20xx7 QuietZone CapSense Starter Kit. To view these parameters, use the Bridge
Control Panel application. Follow these steps to use the Bridge Control Panel with the AEK-
CY8C20xx7 QuietZone CapSense Starter Kit.

1. Click Start > All Programs > Cypress > Bridge Control Panel <version>.

2. Select the device to be connected from the Port Selection window.

3. Select the Variable Settings option from the Chart menu.

4. Upload the .ini file by clicking the Load button. The variable setting file,
Proximity_with_CY8C20xx7.ini, is available in the folder <Projects Direc-
tory>\Starterkit_Example Projects\Proximity with CY8C20xx7\BCP Configu-
ration Files.

5. Upload the .iic file for iic commands that can be sent to the board. The configuration setting file,
Proximity_with_CY8C20xx7.iic, is available in the folder <Projects Direc-
tory>\Starterkit_Example Projects\Proximity with CY8C20xx7\BCP Configu-
ration Files.

6. Go to File > Open File > Proximity_with_CY8C20xx7.iic to select the file for iic commands.

7. Select +1.8 V in the Power Settings box.

8. Click Toggle Power to power the MiniProg3.

9. Click on the ‘W’ line, then click on Send to send the l2C write instruction W 00 00 00 once.

10.Click on the 'R' line, then click on Repeat to send the following l2C read instruction continuously:
R 00 @Sensor_lndex @1RawCount @0RawCount @1Baseline @0Baseline
@1DiffCount @0DiffCount @SensorStatus
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11.Click the Chart tab to view the raw count, baseline, and difference count of the wire sensor.

12.View the required parameters by selecting or clearing the check boxes to the right of the Chart 
view.

13.Click Stop to stop receiving data from the slave device.

14.Click the Table tab to view the values of the demonstration board variables.

Note  Disconnect the MiniProg3 in PSoC Programmer by clicking on the disconnect icon before
opening the Bridge Control Panel.

Figure 3-14.  Bridge Control Panel with CapSense Data
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4. Hardware

4.1 System Block Diagram

Figure 4-1 shows the block diagram of the AEK-CY8C20xx7 QuietZone CapSense Starter Kit. The 
kit can be powered either through the in-system serial programming (ISSP) header or through 
the 14-pin edge connector. The AEK-CY8C20xx7 QuietZone CapSense Starter Kit provides 
flexibility in designing user interface configurations, such as buttons and sliders, and in 
implementing proximity designs.

Figure 4-1.  AEK-CY8C20xx7 QuietZone CapSense Starter Kit Block Diagram

Block Diagram

SmartSense

I2C

GPIO (LED2)

GPIO (LED1)

M8C
MCU

10

CY8C20247S-24LKXI

LD1

Host 
Controller

Button

Proximity

Slider

LD2

Programmer 
(MiniProg3)

ISSP
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4.2 Functional Description

The AEK-CY8C20xx7 QuietZone CapSense Starter Kit has the following components:

■ CY8C20247S-24LKXI

■ CINT - integrating/modulating capacitor, also referred to as CMOD in the Cypress documentation

■ ISSP/I2C header

■ Two onboard LEDs for visual touch feedback

■ 14-pin edge connector1

Figure 4-2.  QuietZone Starter Kit

1. The pins on the 14-pin edge connector and HD1 header are labeled on the back side of the kit.

14‐Pin Edge 
Connector 

5‐Pin Header 
for ISSP/I2C

LEDs

CY8C20247S‐24LKXI

CINT
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4.3 Pin Description

Figure 4-3.  Pinout for CY8C20247S-24LKXI

Table 4-1.  Pin Definitions for CY8C20247S-24LKXI 

Pin No.
Type

Name Description
Digital Analog

1 I/O I P2[5] Crystal output (XOUT)

2 I/O I P2[3] Crystal input (XIN)

3 IOHR I P1[7] I2C SCL, SPI SS

4 IOHR I P1[5] I2C SDA, SPI MISO

5 IOHR I P1[3] SPI CLK

6 IOHR I P1[1] ISSP CLK, I2C SCL, SPI MOSI

7 Power VSS Ground connection

8 IOHR I P1[0] ISSP DATA, I2C SDA, SPI CLK

9 IOHR I P1[2] Driven shield output (optional)

10 IOHR I P1[4] Optional external clock (EXTCLK)

11 Input XRES Active high external reset with internal pull-down

12 IOH I P0[4]

13 Power VDD Supply voltage

14 IOH I P0[7]

15 IOH I P0[3] Integrating input

16 IOH I P0[1] Integrating input

 
Legend A = Analog, I = Input, O = Output, OH = 5-mA High-Output Drive, R = Regulated Output.
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4.4 14-Pin Edge Connector

The 14-pin edge connector is made up of all the GPIOs, the power (VDD), ground (GND), and a
communication interface. Use it to connect with any button or slider sensor hardware. You can
connect the two floating LEDs to any output pin. The schematic view of the connector shows the pin
mapping.

Figure 4-4.  Schematic View of 14-Pin Edge Connector2

4.5 ISSP/I2C Connector

The ISSP is used to program the PSoC device using the MiniProg3 and USB A to Mini-B cable. Plug
the MiniProg3 device into the ISSP header. The ISSP connector is also used to connect the I2C to
the USB bridge to allow communication between the PC and the sensor hardware using the Bridge
Control Panel.

Figure 4-5.  Schematic View of the ISSP Connector

2. The "b" in the labeling indicates the connection to the other end of the 560-ohm resistor. The complete schematics is available in the Appendix
on page 31.
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5. Example Projects

This chapter describes the example projects that implement a button and a slider. The proximity sen-
sor example project is described in detail in the Kit Operation chapter on page 12 and is not
repeated here.

5.1 Implementing Buttons with the AEK-CY8C20xx7

This example project shows you how to implement a button with the SmartSense_EMCplus User
Module using AEK-CY8C20xx7. For proper operation of capacitive sensing, the sensors must be
tuned correctly, which is done automatically by the SmartSense Auto-tuning algorithm. This example
project uses the SmartSense Auto-tuning algorithm, eliminating the need for manual tuning.

5.1.1 Hardware

■ AEK-CY8C20xx7 QuietZone CapSense Starter Kit

■ Button hardware (create using copper tape, as described in Kit Operation on page 12)

■ MiniProg3 programmer

■ USB A to Mini-B cable

■ Connecting wires

5.1.2 Board Setup

1. Connect the MiniProg3 to the ISSP header on the AEK-CY8C20xx7 QuietZone CapSense Starter 
Kit.

2. Connect the other end of the MiniProg3 to your PC using the USB A to Mini-B cable.

The pin assignments used in this example project are:

■ Button - P0[1]

■ LED - P1[4]
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Figure 5-1.  Starter Kit Connections for Button with CY8C20xx7

You can assign any available pin on 14-pin edge connector for the button using the 
SmartSense_EMCplus User Module Wizard. Refer to the user module datasheet, accessible 
through PSoC Designer, for information about configuring pins using the User Module Wizard.

■ To open PSoC Designer, click Start > All Programs > Cypress > PSoC Designer <version> > 
PSoC Designer <version>.

■ Click File > Open Project. Browse to <Projects Directory>\StarterKit_Example 
Projects\Button with CY8C20xx7\button_with_CY8C20xx7 
\button_with_CY8C20xx7.app. 

5.1.3 Firmware Operation

■ Global interrupts are enabled and the SmartSense_EMCplus User Module is started.

■ All sensors are scanned continuously in an infinite loop.

■ When a button (BTN) press is detected, the LED is turned on; the LED is turned off when the but-
ton is released.

■ The I2C communication is set up, and raw counts, baseline, and difference counts parameters 
are continuously sent to an I2C master host (Bridge Control Panel).

5.1.4 Running the Example Project

1. Connect the button hardware with a connecting wire to the configured pin that is labeled P01 on 
the 14-pin edge connector of the starter kit.

2. Use a connecting wire to solder together the pins labeled LED1 and P14.

3. Set voltage to 1.8 V and click on the Power button in PSoC Programmer to power the starter kit.

4. Using PSoC Programmer, program the CY8C20247S-24LKXI with the hex file located in the 
Button_with_CY8C20xx7 directory within the Button with CY8C20xx7 example project.

5. Touch the button (copper pad); the LED labeled LD1 lights up.

6. Monitor the raw count, baseline, and difference counts using the Bridge Control Panel, as 
described in section 5.1.5 Monitoring Sensor Data Using the Bridge Control Panel.

5.1.5 Monitoring Sensor Data Using the Bridge Control Panel

1. Use the MiniProg3 and USB A to Mini-B cable to connect your computer to the ISSP connector of 
the AEK-CY8C20xx7 QuietZone CapSense Starter Kit board. 

P01

P14

LED1LD1
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2. On your PC, select Start > All Programs > Cypress > Bridge Control Panel (version) >
Bridge Control Panel (version).

3. Select the device from the Port Selection window.

4. Power the AEK-CY8C20xx7 QuietZone CapSense Starter Kit board at 1.8 V.

5. From the Bridge Control Panel, select File > Open. Load the Button_with_CY8C20xx7.iic file
from the BCP Configuration Files folder, located in the example project folder.

6. Select Charts > Variable Settings. Load the Button_with_CY8C20xx7.ini file from the BCP Con-
figuration Files folder, located in the example project folder.

7. Click OK to return to the main window.

Figure 5-2.  Bridge Control Panel View

To read the raw count, baseline, and difference count of the sensor:

1.

Click on the 'R' line, then click on Repeat to send the following I2C read instruction continuously: 
R 00 @1RawCount @0RawCount @1Baseline @0Baseline @1DiffCount 
@0DiffCount @Buttonstatus

3. Click the Chart tab to view the raw count, baseline, and difference count of the sensor.

2.

Click on the ‘W’ line, then click on Send to send the l2C write instruction W 00 00 00 once.
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5.2 Implementing Sliders with the AEK-CY8C20xx7

This example project demonstrates the implementation of a five-segment slider with the
SmartSense_EMCplus User Module using AEK-CY8C20xx7. For proper operation of capacitive
sensing, the sensors must be tuned correctly, which is done automatically by the SmartSense Auto-
tuning algorithm. The CapSense parameters are sent via the I2C and can be read using the Bridge
Control Panel.

5.2.1 Hardware

■ AEK-CY8C20xx7 QuietZone CapSense Starter Kit

■ Slider hardware (create using copper tape, as described in Kit Operation on page 12)

■ MiniProg3 programmer

■ USB A to Mini-B cable

■ Connecting wires

5.2.2 Board Setup

1. Connect the MiniProg3 to the ISSP header on the AEK-CY8C20xx7 QuietZone CapSense Starter 
Kit.

2. Connect the other end of the MiniProg3 to your PC using the USB A to Mini-B cable.

The pin assignments used in this example project are:

■ SLD0 - P0[4]

■ SLD1 - P0[7]

■ SLD2 - P1[7]

■ SLD3 - P1[5]

■ SLD4 - P1[3]

■ LED - P1[4]

■ CMOD - P0[3]

Figure 5-3.  Starter Kit Connections for Slider with CY8C20xx7

You can assign any available pin on the 14-pin edge connector for the slider segments, using the
SmartSense_EMCplus User Module Wizard. Refer to the user module datasheet, accessible
through PSoC Designer, for information about configuring pins using the User Module Wizard.

P13

P17
P15

P07
P04
P14

LED1LD1
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■ To open PSoC Designer, click Start > All Programs > Cypress > PSoC Designer <version> >
PSoC Designer <version>.

■ Click File > Open Project. Browse to <Projects Directory>\StarterKit_Example
Projects\Slider with CY8C20xx7\slider_with_CY8C20xx7
\slider_with_CY8C20xx7.app.

5.2.3 Firmware Operation

■ Global interrupts are enabled and the SmartSense_EMCplus User Module is started.

■ All sensors are scanned continuously in an infinite loop.

■ When a slider segment (SLD0–SLD4) press is detected, the LED turns on and the changes in the
SliderCentroid parameter can be observed in the Bridge Control Panel.

5.2.4 Running the Example Project

1. Connect the slider segments SLD0, SLD1, SLD2, SLD3, and SLD4 with connecting wires to the
configured pins that are labeled P04, P07, P17, P15, and P14 respectively.

2. Use a connecting wire to solder the pins labeled LED1 and P14.

3. Set voltage to 1.8 V and click on the Power button in PSoC Programmer to power the starter kit.

4. Using PSoC Programmer, program the CY8C20247S-24LKXI with the hex file located in the
Slider_with_CY8C20xx7 directory within the Slider with CY8C20xx7 example project.

5. Touch the slider segments (copper pad); the LED labeled LD1 lights up.

6. Touch the slider (copper tape) and see the difference in the SliderCentroid parameter in the
Bridge Control Panel.

5.2.5 Monitoring Sensor Data Using the Bridge Control Panel

To run the example project and to read back the CapSense data on the Bridge Control Panel, follow
these steps.

1. Connect your computer to the ISSP connector using the MiniProg3 and USB A to Mini-B cable.

2. Go to Start > Cypress > Open Bridge Control Panel.

3. Select the device from the Port Selection window.

4. Power the kit at 1.8 V.

5. Select File > Open. Load the Slider_with_CY8C20xx7.iic file from the BCP Configuration Files
folder, located in the example project folder.

6. Select Charts > Variable Settings. Load the Slider_with_CY8C20xx7.ini file from the BCP Con-
figuration Files folder, located in the example project folder.

7. Click OK to return to the main window.

8. Observe the CapSense parameters – the raw count, baseline, difference count, slider position,
and sensor on/off status – for the different slider segments in the Bridge Control Panel following 
the instructions in Monitoring Sensor Data Using the Bridge Control Panel on page 27. Without 
touch, the slider position value will be 255.
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A. Appendix

A.1 Schematic

Figure A-1.  AEK-CY8C20xx7 Schematic
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A.2 Board Layouts

Figure A-2.  Top Layer

Figure A-3.  Bottom Layer



AEK-CY8C20xx7 QuietZone CapSense Starter Kit User Guide 33

Figure A-4.  Top Silkscreen Overlay

Figure A-5.  Bottom Silkscreen Overlay
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A.3 Bill of Materials

QuietZone™, SmartSense™, PSoC Designer™ and PSoC Programmer™ are trademarks and PSoC® and CapSense® are registered
trademarks of Cypress Semiconductor Corporation. All other trademarks or registered trademarks referenced herein are property of the
respective corporations.

No. Qty. Reference Description Manufacturer Manufacturer Part No.

1 1 C1 CAP CER 1UF 10V 10% X5R
Murata Electronics North 
America

GRM188R61A105KA61D

2 1 C2 CAP CER 0.1UF 25V Y5V
Murata Electronics North 
America

GRM188F51E104ZA01D

3 1 CINT
CAP CER 2200PF 50V 10% 
X7R

Kemet C0603C222K5RACTU

4 2 LD1, LD2
LED SUPER RED CLEAR 
SMD

Lite-ON Inc LTST-C190KRKT

5 10
R07, R04, R14, 
R12, R13, R15, 
R17, R23, R25, R01

RES 560 OHM 1/10W 5% 
SMD

Yageo RC0603JR-07560RL

6 1 U1 CapSense PSoC Cypress Semiconductor CY8C20247-24LKXIT

7 1 ISSP DNP, Ship with Boards
Sullins Connector Solu-
tions

SWR25X-NRTC-S05-RB-BA

8 1
CY3240B-16QFN 
Small Stamp Board

Goldern Pheonix CY3240C-16QFN SS Brd

9 1 SMD Assembly
Singulated and packed in 
mailers

AratFlex

10 2 Address Label Avery 5161

11 2 Logo Label Avery 5161

12 20 Rear Label Avery 5126

13 1 Mailer Insert DVDieCutting.Com Custom Card Board Insert

14 1 Shipping Canada Post
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